All We Ever Wanted Was Everything (Bauhaus Cover)

A No Vocals cover of the Bauhaus song “All We Ever Wanted Was Everything”. This was done with my usual setup of Caustic, my Keystation Mini(as pictured), with some finishing in Sonar X3.

I started out doing a cover of one of my favorite Bauhaus songs, “In The Night”. As I went about it, I felt more and more like it just wasn’t translating well. A lot of was really due to the numerous tempo changes, a lot of bendy guitar parts, and not really a lot of room to play with the drums as much. Something “All We Ever Wanted” did afford, although I did keep it to a minimum. I did finish “In The Night”, but as I sat down to listen back to it a few times, I figured “The Sky’s Gone Out” had a ton of great songs on it. So I loaded it up and gave it a listened. Any excuse to listen to this album is fine by me.

Doing some kind of long form, extended mix of “Three Shadows” had crossed my mind, but I am still working on that album, and just wanted a quick diversion I could toss online by the end of the weekend. The much shorter “All We Ever Wanted” seemed more ideal for that. Additionally, I liked the idea of doing a mostly acoustic song. It had some really great bass parts, and they translated well with the keyboard without much trouble at all.

These two songs are also the first I completed from start to finish on the new computer setup. Last weekend I had been working on some songs from Twin Peaks, and while recording parts of it the computer had crashed on multiple attempts. That PC is particularly more impressive, but it was formerly a cryptocoin miner, and time has taken quite the toll on it. I plan to get it back in stable running order, but I decided it was time to get a more dedicated music solution together.

I had an older Phenom II X6 Black Edition CPU just sitting in a box, along with some other older parts, I just needed a case and power supply unit and I could at least be up and running. My younger brother had just finish building his new dream PC, and just so happened to have an old computer not in use. So I commandeered this, and plugged in the aforementioned CPU, and my Hyper X ram (he had some mix matched stuff in there). I hit the power button to reveal… nothing. It wasn’t even turning on. I swapped back in his old parts and still nothing. It had at least been turning on before he had replaced it. I still had another older motherboard, and simply hooked that in, with my CPU and other parts. Turned it on and it booted no problem. Cool.

I plugged in the rest, put the case back together, and turned it on again. I was immediately met with a loud CRACK and a small white blue flash on top of the board. Even now I am not sure what caused it. I thought I smelled some burnt cat hair, maybe some landed on the wrong spot? The CPU in the other board had some really old thermal paste that was also flaking everywhere. Maybe a small bit fell on the board when I put the case back together? I don’t know. What I did know that board was now dead too.

So I didn’t have a lot of options left at this point. I went ahead and ordered a new MSI motherboard, and a couple other small things. It arrived the end of last week, and it all went together smoothly. Additional USB 3.1 slots, new 3tb drive to go along with the SSD, plus my older k800 Logitech keyboard works again with this computer for some reason. It was all for the best I suppose. I’d do a full detailed breakdown of what I am using, but I am looking to slowly swap some things out. Maybe save that for another time.